Excel ISTNV Funktion: den #NV Fehler erkennen

Excel Insights: Excel ISTNV Funktion

Die Excel ISTNV Funktion gehört zu den Ist-Funktionen aus der Kategorie der Informationsfunktionen. Sie erkennt, ob andere Formeln und Funktionen den Fehlerwert #NV zurückgeben. Im Zusammenspiel mit der WENN Funktion kannst du für diesen Fall ein abweichendes Verhalten definieren.

Während der Grund für die anderen Fehlerwerte wie z.B. WERT!, #BEZUG! etc. oft ein Anwendungsfehler ist, tritt der #NV Fehler hauptsächlich auf, wenn ein mit einer Verweis-Funktion gesuchtes Element nicht gefunden werden kann. Deshalb ist die separate Identifizierung des Fehlerwertes #NV durch die separate Excel ISTNV Funktion eine schöne Sache.


Übersicht

  1. Excel ISTNV Funktion: Syntax und Funktionsweise
  2. Beispiele zur Excel Funktion ISTNV
  3. Ressourcen

1. Excel ISTNV Funktion:
Syntax und Funktionsweise

Immer wenn es darum geht, ob eine Funktion den Fehlerwert #NV zurückgibt, solltest du entweder die hier thematisierte Funktion ISTNV oder die Funktion WENNNV verwenden.

Die Syntax der Excel ISTNV Funktion gestaltet sich wie folgt:

=ISTNV(Wert)

Wert ist das Argument, das hier auf den #NV Fehler überprüft werden soll. Nur wenn der Wert selber #NV ist oder wenn eine Funktion den Fehlerwert #NV als Rückgabewert liefert, gibt die Excel ISTNV Funktion den Rückgabewert WAHR zurück.

Andere Werte wie z.B. Zahlen, Texte, Datumswerte, Wahrheitswerte aber auch anderen Fehlerwerte wie z.B. WERT!, #BEZUG!, #DIV/0, #ZAHL! etc. führen dazu, dass die ISTNV Funktion den Rückgabewert FALSCH zurückgibt. Das unterscheidet sie von der Excel Funktion ISTFEHLER.

Hier wird das schön deutlich:

Excel Insights: Screenshot Funktionsweise Excel ISTNV Funktion
Die Excel ISTNV Funktion identifiziert nur den #NV Fehler

2. Beispiel: Excel ISTNV Funktion mit SVERWEIS

Der SVERWEIS ist die bekannteste Funktion aus der Kategorie Nachschlagen und Verweisen. Wenn es das Suchkriterium in der zu durchsuchenden Spalte gar nicht gibt, der SVERWEIS also keinen Treffer in den Daten finden konnte, gibt die Funktion den Fehlerwert #NV zurück.

Falls du in diesem Fall nur einen anderen Wert als #NV ausgeben lassen willst, dann solltest du direkt die Funktion WENNNV verwenden. Das kann z.B. Sinn machen, wenn du anstatt #NV einfach eine 0 als Rückgabewert benötigst, um damit weiterrechnen zu können.

Dieses Beispiel hier ist jedoch anders gelagert. In einer Liste sind Aluminium L-Profile mit ihrer Artikel-Nr. und ihren Eigenschaften notiert. Die Artikel-Nr. folgt zwar einer Logik, allerdings werden die Artikel-Nr. erst vergeben, wenn das erste Mal ein Artikel in der entsprechenden Länge bestellt wird:

Mit einem SVERWEIS wird dann in der Liste überprüft, ob es die Artikel-Nr. aus der Zelle A11 bereits gibt:

=SVERWEIS(A11;$A$4:$D$9;1;0)

Der Spaltenindex ist hier egal, da wir eigentlich keinen der Werte aus der Tabelle als Rückgabewert ausgeben wollen. Du kannst also jeden Wert zwischen 1 (Spalte A) und 4 (Spalte D) angeben.

Wenn es die Artikel-Nr. aus der Zelle A11 in der Tabelle gibt, liefert der SVERWEIS den Wert aus der angegebenen Spalte, wenn die Artikel-Nr. gar nicht (bzw. noch nicht) existiert, liefert der SVERWEIS den Fehlerwert #NV zurück.

Du kannst also mit der Funktion ISTNV und der Funktion SVERWEIS in Kombination überprüfen, ob es den gesuchten Wert gibt oder nicht:

=ISTNV(SVERWEIS(A11;$A$4:$D$9;1;0))

Der Rückgabewert der Funktion ISTNV ist WAHR, wenn der SVERWEIS den #NV Fehler zurückgibt, oder FALSCH, wenn der SVERWEIS einen Wert zurückgibt.

Mit einer WENN Funktion unterscheiden wir jetzt noch die beiden Fälle und bauen sowohl für den DANN- als auch den SONST-Fall Ausgabetexte mit der Artikel-Nr. zusammen:

=WENN(ISTNV(SVERWEIS(A11;$A$4:$D$9;1;0));
"Die Artikel-Nr. "&A11&" existiert nicht.";
"Die Artikel-Nr. "&A11&" existiert bereits.")

3. Ressourcen

Hier findest du noch ein paar Artikel mit weiterführenden Informationen, die Beispieldatei zum Download und externe Links:


Kommentar verfassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.


Die im Rahmen der Kommentarfunktion übermittelten Daten werden gespeichert. Weitere Informationen zur Datenverarbeitung findest du in der Datenschutzerklärung.