Excel N Funktion: Wert als Zahl ausgeben

Excel Insights: Die Excel N Funktion gibt Werte als Zahl aus

Die Excel N Funktion gehört zu der Gruppe der Informationsfunktionen und gibt einen Wert als Zahl zurück. Mit der N Funktion kannst du dir z.B. die booleschen Werte WAHR und FALSCH als Zahlen 1 oder 0 ausgeben oder auch den einen Datumswert als Zahl anzeigen lassen.

Damit kann die N Funktion auch in der Datenverarbeitung hilfreich sein, wenn du z.B. Spalten nach gewissen Elementen mit der Funktion SUMMENPRODUKT filtern willst.


Übersicht

  1. Syntax und Funktionsweise
  2. Beispiele
  3. Ressourcen

1. Excel N Funktion: Syntax und Funktionsweise

Die Syntax der Funktion ??? gestaltet sich wie folgt:

=N(Wert)

Der Wert kann ein beliebiger Wert sein. Es ist unerheblich, ob du diesen Wert direkt in der Funktion angibst, ob du eine andere Funktion oder Formel einsetzt oder auch auf eine Zelle verweist. Die Rückgabewerte der Funktion N sind abhängig von den ursprünglichen Werten:

Excel Insights: Die Excel N Funktion hat abhängig vom zu überprüfenden Wert folgende Rückgabewerte
Abhängig vom zu prüfenden Wert gibt die Funktion N folgende Rückgabewerte aus

WertBeispielRückgabewert
Zahlen 2109,12 2109,12
Boolesche WerteWAHR1
FALSCH0
Datumswerte12.03.202043902
Fehlerwerte#NV#NV
#WERT!#WERT!
#BEZUG!#BEZUG!
#DIV/0!#DIV/0!
#ZAHL!#ZAHL!
#NAME?#NAME?
#NULL!#NULL!
Texte„Kostenstelle“0
alle anderen Werte0

2. Beispiel zur Excel N Funktion

Die Funktion SUMMENPRODUKT filtert eine Tabelle nach Einträgen und addiert die zugehörigen Werte dieser Einträge. In der von Excel vorgesehenen Array-Schreibweise funktioniert das nur, wenn die booleschen Rückgabewerte zunächst in eine Zahl gewandelt werden.

Die Spalte A Country soll nach dem Land „Germany“ durchsucht und die Umsätze in der Zelle E3 addiert werden:

Excel Insights: Mit der Excel N Funktion boolesche Werte umwandeln
Die Überprüfung der Spalte A nach „Germany“ liefert je Zeile einen booleschen Wert WAHR oder FALSCH, der mit der Funktion N in 1 oder 0 umgewandelt wird

Die Formel in Zelle E3 lautet:

=SUMMENPRODUKT(N(A7:A36=A3);E7:E36)

Die Funktion SUMMENPRODUKT addiert für jede Zeile, in der für den Suchbereich A7:A36 der Suchwert „Germany“ aus der Zelle A3 gefunden wird, den zugehörigen Wert aus dem Wertebereich E7:E36. Von 1.200.000 Umsatz enfallen 100.000 auf „France“. Das Ergebnis 1.100.000 für „Germany“ ist also korrekt.

Das Funktioniert aber nur, wenn die Excel N Funktion um den Wahrheitstest gesetzt wird. Denn der Wahrheitstest A7:A36=A3 liefert je Zeile einen booleschen Rückgabewert WAHR oder FALSCH. Aufgrund der Array-Schreibweise kann die Funktion SUMMENPRODUKT mit den booleschen Werten kein Produkt bilden. Die folgende Formel würde also immer das Ergebnis 0 ergeben:

=SUMMENPRODUKT(A7:A36=A3;E7:E36)

Wie die Funktion SUMMENPRODUKT technisch genau funktioniert, was du damit machen kannst, welche Filterkombinationen möglich sind und alternative Schreibweisen zur Array-Schreibweise findest du im Artikel zur Datenauswertung mit SUMMENPRODUKT.


3. Ressourcen

Hier findest du noch ein paar Artikel mit weiterführenden Informationen, die Beispieldatei zum Download und externe Links:

Kommentar verfassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.


Die im Rahmen der Kommentarfunktion übermittelten Daten werden gespeichert. Weitere Informationen zur Datenverarbeitung findest du in der Datenschutzerklärung.

Scroll to Top