Excel WERT Funktion: Text in Zahl umwandeln

Excel Insights: Excel WERT Funktion: Text in Zahl konvertieren

Die Excel WERT Funktion gehört zu der Gruppe der Textfunktionen und wandelt Werte im Format Text in das Format Zahl um. Für eine einfache Berechnung ist das gar nicht nötig, da Excel z.B. auch mit Werten im Format Text rechnen kann.

Das wirkliche Einsatzgebiet der Funktion WERT ist jedoch die Umwandlung der Rückgabewerte anderer Textfunktionen in das Format Zahl. Für den logischen Abgleich von Werten im Rahmen von Wahrheitstests kannst du nämlich keine Äpfel mit Birnen vergleichen.


Übersicht

  1. Excel WERT Funktion: Syntax und Funktionsweise
  2. SVERWEIS, LINKS und Excel WERT Funktion
  3. Weitere Beispiele
  4. Ressourcen

1. Excel WERT Funktion: Syntax und Funktionsweise

Die Syntax der Funktion WERT gestaltet sich wie folgt:

=WERT(Text)

Der Text ist der Wert im Format Text, der in das Format Zahl konvertiert werden soll. Der Text muss – wie in Formeln und Funktionen üblich – in Anführungszeichen angegeben werden. Alternativ kannst du natürlich auch einen Zellbezug oder eine Textfunktion angeben.

Im Endeffekt funktioniert das Umwandeln in einen numerischen Wert mit der WERT Funktion mit allen Excel Datenformaten:

Excel Insights: Text nach Zahl umwandeln
Mit der Excel WERT Funktion andere Datenformate in numerische Werte umwandeln.

Doch ergibt diese Umwandlung nur bedingt Sinn, da Excel auch mit Werten, die nicht im Fomat Zahl vorliegen, rechnen kann. Das wahre Einsatzgebiet der WERT Funktion lernst du im folgenden Beispiel kennen:


Ein einfach gestricktes Praxisbeispiel soll den korrekten und sinnvollen Einsatz der WERT Funktion verdeutlichen.

Ein Datenexport aus dem Finanzbuchaltungssystem zeigt die einzelnen bebuchten Konten inklusive Ihrer Salden zum Zeitpunkt X. Die einzelnen Konten sollen mit Hilfe der Funktion SVERWEIS und einer zweiten Tabelle kategorisiert werden. Das Suchkriterium ist die erste Ziffer der Kontonummer, die mit Hilfe der Excel LINKS Funktion extrahiert werden kann.

Die verwendete Formel in der Zelle D5 lautet:

=SVERWEIS(LINKS(A5;1);$A$12:$B$13;2;0)

Das Suchkriterium ist hier die erste Ziffer des Wertes in der Zelle A5. Obwohl die Formel an sich funktionieren könnte (siehe unten), liefert sie nur den #NV Fehler. Der Rückgabewert der LINKS Funktion ist ein Text, die Werte in den Zellen A12 und A13 sind jedoch Zahlen.

Merke: Ein Vergleich von Äpfeln und Birnen ist nicht möglich.

An der Hilfsspalte wird für das geschulte Auge deutlich, dass das Ergebnis keine Zahl sondern ein Text ist. Texte werden linksbündig angeordnet, Zahlen jedoch rechtsbündig, wie man an den Spalten A bis C sehen kann:

Excel Insights: Werte vom FOrmat Text erkennt man an der linksbündigen Ausrichtung
Die linksbündige Ausrichtung der Werte in Spalte D lässt erkennen, es handelt sich um Texte, nicht um Zahlen.

Der SVERWEIS in der Zelle E5 lautet:

=SVERWEIS(D5;$A$12:$B$13;2;0)

Die Formel für die Hilfsspalte in der Zelle D5 lautet:

=LINKS(A5;1)

Hier kommt die Funktion WERT zur Anwendung:

Excel Insights: Die Excel WERT Funktion mit LINKS
Die Excel WERT Funktion macht aus dem Rückgabewert der Funktion LINKS eine Zahl

Die Formel (wieder ohne Hilfsspalte) in der Zelle D5 lautet:

=SVERWEIS(WERT(LINKS(A5;1));$A$12:$B$13;2;0)

Die Funktion WERT macht aus dem Rückgabewert der LINKS Funktion eine Zahl, die der SVERWEIS in der zweiten Tabelle nun auch finden kann.


3. weitere Beispiele

coming soon


4. Ressourcen

Hier findest du noch ein paar Artikel mit weiterführenden Informationen, die Beispieldatei zum Download und externe Links:


Kommentar verfassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.


Die im Rahmen der Kommentarfunktion übermittelten Daten werden gespeichert. Weitere Informationen zur Datenverarbeitung findest du in der Datenschutzerklärung.

Scroll to Top